$re = '/[A-Z]{2,3}-[0-6][0-9]{2}/';
$str = 'BR-092
PR-754';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);