re = /^[a-z0-9]+@[a-z]+\.[a-z]+$/m
str = 'leminhhung2132434544@gmail.com
&^&^%%$$(*&*&&leminhhung@gmail.com*&%%*%%&%^&$
&*^^*&^^^^^^leminhhung@gmail.com
leminhhung@gmail.com&*^^*&^^^^^^
leminhhung@gmail.com &*^^*&^^^^^^
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end