# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\S+) = .*VOS_Malloc\(\S+, .*\);.*memset_s\s*\([^,]*\1[^,]*, ([^,]+), [^,]+, ([^,]+)\);"
test_str = ("            pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);\n"
	"            if (NULL == pNewBuf) {\n"
	"                (VOID)VOS_Free(tmp_buf);\n"
	"                *buf = NULL;\n"
	"                return VOS_ERR;\n"
	"            }\n"
	"            (VOID)memset_s ((CHAR *)(pNewBuf), tmp_length, 0, tmp_length);\n\n"
	"            nRet = memcpy_s ((VOID *)(pNewBuf), (VOS_UINT32)tmp_length, (VOID *)(tmp_buf), (VOS_UINT32)tmp_offset);\n"
	"            VOS_DBGASSERT(nRet == VOS_OK);\n"
	"            (VOID)VOS_Free(tmp_buf);\n\n"
	"            pNewBuf = (CHAR *)VOS_Malloc(VASP_AAA_MID, tmp_length * xxx);\n"
	"            if (NULL == pNewBuf) {\n"
	"                (VOID)VOS_Free(tmp_buf);\n"
	"                *buf = NULL;\n"
	"                return VOS_ERR;\n"
	"            }\n"
	"            (VOID)memset_s ((CHAR *)(pNewBuf), tmp_length * 3, 0, tmp_length);\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.