import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?pop_([^_]+)_throughput_\\1.*$";
final String string = "example_pop_high_throughput_high_strategy.csv\n"
+ "example_pop_high_throughput_base_strategy.csv\n"
+ "example_pop_high_throughput_low_strategy.csv\n"
+ "example_pop_base_throughput_high_strategy.csv\n"
+ "example_pop_base_throughput_base_strategy.csv\n"
+ "example_pop_base_throughput_low_strategy.csv\n"
+ "example_pop_low_throughput_high_strategy.csv\n"
+ "example_pop_low_throughput_base_strategy.csv\n"
+ "example_pop_low_throughput_low_strategy.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}