#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.*\d/\h*\d.*(?:\R.*)*?\REND OF REPORT\b"
Local $sString = "TRAFFIC MEASUREMENT REPORT PART 1/ 6 VLR MEASUREMENT VLRMEAS " & @CRLF & _
"" & @CRLF & _
"SAMPLE DATE: FROM 2020-10-22 14:00:00:09" & @CRLF & _
" TO 2020-10-22 15:00:00:13" & @CRLF & _
"" & @CRLF & _
"REGISTERED SUBSCRIBERS:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"LOCATION AREA CODE CURRENT AVERAGE TMS1 TMS2 TMS3" & @CRLF & _
" UNKNOWN LAC 2 2 0 0 0" & @CRLF & _
" 113 75868 75749 0 0 0" & @CRLF & _
" 115 40627 40732 0 0 0" & @CRLF & _
" 1102 70422 70489 0 0 0" & @CRLF & _
" 1105 87075 87067 0 0 0" & @CRLF & _
" 1117 56150 56180 0 0 0" & @CRLF & _
" 1118 67175 67444 0 0 0" & @CRLF & _
" 1120 74385 74381 0 0 0" & @CRLF & _
" 1121 65034 65060 0 0 0" & @CRLF & _
" 1122 21636 21407 0 0 0" & @CRLF & _
" 1217 22944 22856 0 0 0" & @CRLF & _
" 1218 49054 48993 0 0 0" & @CRLF & _
" 1318 24283 24066 0 0 0" & @CRLF & _
" 1418 16366 16350 0 0 0" & @CRLF & _
" 2118 17812 17674 0 0 0" & @CRLF & _
" 2120 79644 79489 0 0 0" & @CRLF & _
"TOTAL 768477 767939 0 0 0" & @CRLF & _
"" & @CRLF & _
"PART 1/ 6" & @CRLF & _
"END OF REPORT" & @CRLF & _
"" & @CRLF & _
"testing some data" & @CRLF & _
"here" & @CRLF & _
"" & @CRLF & _
"TRAFFIC MEASUREMENT REPORT PART 2/ 6 VLR MEASUREMENT VLRMEAS " & @CRLF & _
"" & @CRLF & _
"SAMPLE DATE: FROM 2020-10-22 14:00:00:09" & @CRLF & _
" TO 2020-10-22 15:00:00:13" & @CRLF & _
"" & @CRLF & _
"REGISTERED SUBSCRIBERS:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"LOCATION AREA CODE CURRENT AVERAGE TMS1 TMS2 TMS3" & @CRLF & _
" UNKNOWN LAC 2 2 0 0 0" & @CRLF & _
" 113 75868 75749 0 0 0" & @CRLF & _
" 115 40627 40732 0 0 0" & @CRLF & _
" 1102 70422 70489 0 0 0" & @CRLF & _
" 1105 87075 87067 0 0 0" & @CRLF & _
" 1117 56150 56180 0 0 0" & @CRLF & _
" 1118 67175 67444 0 0 0" & @CRLF & _
" 1120 74385 74381 0 0 0" & @CRLF & _
" 1121 65034 65060 0 0 0" & @CRLF & _
" 1122 21636 21407 0 0 0" & @CRLF & _
" 1217 22944 22856 0 0 0" & @CRLF & _
" 1218 49054 48993 0 0 0" & @CRLF & _
" 1318 24283 24066 0 0 0" & @CRLF & _
" 1418 16366 16350 0 0 0" & @CRLF & _
" 2118 17812 17674 0 0 0" & @CRLF & _
" 2120 79644 79489 0 0 0" & @CRLF & _
"TOTAL 768477 767939 0 0 0" & @CRLF & _
"" & @CRLF & _
"PART 2/ 6" & @CRLF & _
"END OF REPORT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")