re = /^\s*(([+]?((0?(\.[0-9]*)?|\.[0-9]+)|1(\.0*)?)([Ee][+-]?[0-9]+)?)\s+){3}([+]?((0?(\.[0-9]*)?|\.[0-9]+)|1(\.0*)?)([Ee][+-]?[0-9]+)?)\s*$/m
str = '1 1.0 1 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end