#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[2][0-3]|[10][0-9])[ :][0-5][0-9][ :][0-5][0-9]"
Local $sString = "12:59:23" & @CRLF & _
"01:01:01" & @CRLF & _
"11:11:11" & @CRLF & _
"23:59:59" & @CRLF & _
"24:15:65" & @CRLF & _
"99:99:14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")