#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[( ]\K(?!red\b|blue\b|green\b)[a-z]+"
Local $sString = "(green:bar AND black:foo)" & @CRLF & _
"(blue:bar AND darkblue:foo)" & @CRLF & _
"(yellow:bar AND grey:foo)" & @CRLF & _
"(greengarden:bar AND red:foo)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")