package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[-+]?\d*$`)
var str = `120
45
-56`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}