# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*)object\s(\w*):\sTcxRadioGroup.*?\n\1end"
test_str = ("object Form1: TForm1\n"
" Left = 0\n"
" Top = 0\n"
" Caption = 'Form1'\n"
" ClientHeight = 494\n"
" ClientWidth = 635\n"
" Color = clBtnFace\n"
" Font.Charset = DEFAULT_CHARSET\n"
" Font.Color = clWindowText\n"
" Font.Height = -11\n"
" Font.Name = 'Tahoma'\n"
" Font.Style = []\n"
" OldCreateOrder = False\n"
" PixelsPerInch = 96\n"
" TextHeight = 13\n"
" object cxRadioGroup1: TcxRadioGroup\n"
" Left = 0\n"
" Top = 0\n"
" Align = alTop\n"
" Caption = 'cxRadioGroup1'\n"
" Properties.Items = <>\n"
" TabOrder = 0\n"
" ExplicitLeft = 24\n"
" ExplicitTop = 16\n"
" ExplicitWidth = 185\n"
" Height = 105\n"
" Width = 635\n"
" end\n"
" object cxRadioGroup2: TcxRadioGroup\n"
" Left = 0\n"
" Top = 389\n"
" Align = alBottom\n"
" Properties.Items = <>\n"
" TabOrder = 1\n"
" ExplicitTop = 293\n"
" Height = 105\n"
" Width = 635\n"
" end\n"
" object Panel1: TPanel\n"
" Left = 200\n"
" Top = 111\n"
" Width = 257\n"
" Height = 265\n"
" Caption = 'Panel1'\n"
" TabOrder = 2\n"
" object cxRadioGroup3: TcxRadioGroup\n"
" Left = 8\n"
" Top = 16\n"
" Caption = 'cxRadioGroup3'\n"
" Properties.Items = <>\n"
" TabOrder = 0\n"
" Height = 105\n"
" Width = 185\n"
" end\n"
" object cxRadioGroup4: TcxRadioGroup\n"
" Left = 8\n"
" Top = 144\n"
" Properties.Items = <\n"
" item\n"
" Caption = 'item 1'\n"
" end\n"
" item\n"
" Caption = 'item 2'\n"
" end>\n"
" TabOrder = 1\n"
" Height = 105\n"
" Width = 185\n"
" end\n"
" end\n"
"end")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.