#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[_/])[^/_\s]+(?=[^\s/]*\.parquet$)"
Local $sString = "test_stage/parquet_location/9f7d37fd-7039-4454-94ef-2b0cd6c3206a_b1df97ad-54dc-4fc9-a099-1fb9cd6530be_custom_1696963985.parquet" & @CRLF & _
"" & @CRLF & _
"9f7d37fd-7039-4454-94ef-2b0cd6c3206a_b1df97ad-54dc-4fc9-a099-1fb9cd6530be_custom_1696963985.parquet" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")