import Foundation
let pattern = #"create table (\w+)\([\s\S]+?(?=\)(?:\n|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
create table sous_branche(
id_sous_branche integer not null,
code_sous_branche character varying(20) not null,
libelle_sous_branche character varying(55) not null,
designation_sous_branche character varying(255) null,
taux_taxes float null,
date_creation timestamp without time zone null,
ref_importation integer null,
date_importation timestamp without time zone null
)
go
-- **** object: table caisse script date: 30/06/2015 16:53:15 ****
create table operation_caisse(
id_operation_caisse integer not null,
operation_id integer not null,
mode_paiement_id integer not null, --id_mode_paiement
libelle_paiement_caisse_id integer not null, --id_libelle_paiement
jour_imputation timestamp without time zone null,
date_paiement_caisse timestamp without time zone null,
numero_reglement integer null,
libelle_operation_caisse character varying(55) not null,
montant_operation_caisse double precision null,
payeur_effet_caisse_id integer not null, --id_payeur_effet
numero_effet_caisse character varying(30) null,
titulaire_compte_effet_caisse character varying(55) null,
date_encaissement_effet_caisse timestamp without time zone null,
autres_informations_caisse text null,
valider_commissionnement_caisse bit not null,
commissions_a_debiter_caisse real null,
numero_piece_caisse character varying(30) null,
piece_caisse_annulee bit not null,
date_annulation_piece_caisse timestamp without time zone null,
reference_annulation_piece_caisse character varying(55) null,
date_creation timestamp without time zone null,
ref_importation integer null,
date_importation timestamp without time zone null
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)