$re = '`^(?![0-9]*456)[0-9]*$`m';
$str = '0
1456
12345689
1010101
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);