$re = '/([a-zA-Z])..\1..\1/';
$str = 'axxaxxaxx
xaxxaxxax
--a--a--a
-x--x--x-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);