$re = '/(https?):\/\/(\S+)(?:\s+https?:\/\/\2)*/m';
$str = 'http://regex101.com/r/aC9tW2/3
https://regex101.com/r/aC9tW2/3
https://regex101.com/r/aC9tW2/3/
https://www.regex101.com/r/aC9tW2/3
https://www.regex101.com/r/aC9tW2/3/';
$subst = "$1://$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;