$re = '/^[thor ]+|[THOR ]+/m';
$str = 'thor asafasfa
THOR adfjdskfdjk
thor And union
THOR ksfdhkfhkthor
THOR nojsdgdsb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);