#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(.*?])\s(__declspec.+?\)\))(.*?;)"
Local $sString = "#if defined (_MSC_VER) && !defined(__clang__)" & @CRLF & _
" double pU0[3*4*K_MAX_STACK] __declspec(align(64));" & @CRLF & _
"#else" & @CRLF & _
" double pU0[3*4*K_MAX_STACK] __attribute__ ((aligned (64)));" & @CRLF & _
"#endif" & @CRLF & _
"" & @CRLF & _
"#if defined (_MSC_VER) && !defined(__clang__)" & @CRLF & _
" double CC[16] __declspec(align(64)) = {0};" & @CRLF & _
"#else" & @CRLF & _
" double CC[16] __attribute__ ((aligned (64))) = {0};" & @CRLF & _
"#endif" & @CRLF & _
"" & @CRLF & _
"#if defined (_MSC_VER) && !defined(__clang__)" & @CRLF & _
" double pU[3*4*K_MAX_STACK] __declspec(align(64));" & @CRLF & _
"#else" & @CRLF & _
" double pU[3*4*K_MAX_STACK] __attribute__ ((aligned (64)));" & @CRLF & _
"#endif"
Local $sSubst = "$2 $1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)