import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(.*?)(\\s__declspec.+?\\)\\))(.*?;)";
final String string = "#if defined (_MSC_VER) && !defined(__clang__)\n"
+ " double pU0[3*4*K_MAX_STACK] __declspec(align(64));\n"
+ "#else\n"
+ " double pU0[3*4*K_MAX_STACK] __attribute__ ((aligned (64)));\n"
+ "#endif\n\n"
+ "#if defined (_MSC_VER) && !defined(__clang__)\n"
+ " double CC[16] __declspec(align(64)) = {0};\n"
+ "#else\n"
+ " double CC[16] __attribute__ ((aligned (64))) = {0};\n"
+ "#endif\n\n"
+ "#if defined (_MSC_VER) && !defined(__clang__)\n"
+ " double pU[3*4*K_MAX_STACK] __declspec(align(64));\n"
+ "#else\n"
+ " double pU[3*4*K_MAX_STACK] __attribute__ ((aligned (64)));\n"
+ "#endif";
final String subst = "$2 $1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}