package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}/[A-Z]{2}\d{2}/\d{9}/\d{2}$`)
var str = `101/AZ19/500000009/08`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}