$re = '~(?=^(?:\D*\d){2,}$) # at least two numericals
(?=[^A-Z]*[A-Z]) # UPPERCASE
(?=[^a-z]*[a-z]) # lowercase
(?=[^!"§$%&/()=]*[!"§$%&/()=]) # symbol
^\S{8,}$~mx';
$str = 'asdA1@#2.
1Aas&3%A
21asdA@!
aaaAAbsbaa
a1244bdhdhd
aA1@jfjfhg2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);