package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9]{9}(-[0-9])?`)
var str = `123456789-7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}