const regex = /(?<=^# .*⤵(?:\n(?!# ).*)*)\n(^## .*)\n(?!#+ )(.*(?:\n(?!#).*)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^# .*⤵(?:\\n(?!# ).*)*)\\n(^## .*)\\n(?!#+ )(.*(?:\\n(?!#).*)*)', 'gm')
const str = `# Heading 1 ⤵
## Heading 1.1
Text of Heading 1.1
Text can span over multiple lines
Even more text
### Heading 1.1.1
Text of Heading 1.1.1
## Heading 1.2
Text of Heading 1.2
# Heading 2
## Heading 2.1
Text of Heading 2.1
## Heading 2.2
Text of Heading 2.2
# Heading 3 ⤵
## Heading 3.1
Text of Heading 3.1
## Heading 3.2
Text of Heading 3.2
# Heading 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}