$re = '/(?i)name\s*=\s*[\'"]?google-site-verification[^>]+content\s*=\s*[\'"]?([^\'"]*)[\'"]?/';
$str = '<meta name="google-site-verification" content="YOUR CODE HERE" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);