import re
regex = re.compile(r"<span class='pages'>((?:[^<>]*|(?=<!--).*?-->|<((?!span\b)[^> ]+)[^>]*>.*?</\2>)*)</span>", flags=re.MULTILINE)
test_str = "<span class='pages'>1 de <!-- <span> comentado </span> --> <123.-*()x>link</123.-*()x> 8</span><span class='current'>1</span>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")