re = /\b(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\s+(?:0?[1-9]|[12][0-9]|3[01])\s+\d{4}\b/i
str = 'Profile sep 3 2015.txt
Profile mar 25 2014 inactive.txt
Profile Aug 15 2014 inactive.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end