using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Error\s+in\s+heartbeat\s+\(requestId:\s+\d+\)\s+to\s+(?<mongo>[^:]+)";
string input = @"{""time"":""2020-07-24T11:48:21.18957143Z"",""event"":""2020-07-24T11:48:21.189+0000 I REPL_HB [replexec-949] Error in heartbeat (requestId: 649360) to mongodb3:27017, response status: NetworkInterfaceExceededTimeLimit: Couldn't get a connection within the time limit\n"",""hostname"":""node2""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}