#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m){\[%clk \d+:\d+:\d+(\.\d+)?\]}"
Local $sString = "'1. e4 {[%clk 0:29:59.9]} 1... e5 {[%clk 0:29:59.1]} 2. Nf3 {[%clk 0:29:58]} 2... Nf6 {[%clk 0:29:57.2]} 3. Nc3 {[%clk 0:29:51.9]} 3... Bb4 {[%clk 0:29:51.9]} 4. a3 {[%clk 0:29:49.4]} 4... Ba5 {[%clk 0:29:46.3]} 5. Bc4 {[%clk 0:29:44.7]} 5... O-O {[%clk 0:29:37.5]} 6. Ng5 {[%clk 0:29:37.9]} 6... d6 {[%clk 0:29:10]} 7. O-O {[%clk 0:29:35.7]} 7... Be6 {[%clk 0:28:41.8]} 8. Nxe6 {[%clk 0:29:19]} 8... fxe6 {[%clk 0:28:33.2]} 9. b4 {[%clk 0:29:13.9]} 9... Bb6 {[%clk 0:28:21.6]} 10. a4 {[%clk 0:29:08.4]} 10... d5 {[%clk 0:27:53.9]} 11. exd5 {[%clk 0:29:06.1]} 11... exd5 {[%clk 0:27:51.4]} 12. Be2 {[%clk 0:28:45.8]} 12... Ne4 {[%clk 0:27:40.6]} 13. Nxe4 {[%clk 0:28:21.8]} 13... dxe4 {[%clk 0:27:38.2]} 14. a5 {[%clk 0:28:17.2]} 14... Qh4 {[%clk 0:26:02.6]} 15. Bc4+ {[%clk 0:27:59.7]} 15... Kh8 {[%clk 0:25:44.7]} 16. g3 {[%clk 0:27:57.3]} 16... Qe7 {[%clk 0:25:18.4]} 17. d3 {[%clk 0:27:34.4]} 17... Qxb4 {[%clk 0:24:59.4]} 18. Bg5 {[%clk 0:27:10.1]} 18... Qxa5 {[%clk 0:24:40.1]} 19. d4 {[%clk 0:26:58.3]} 19... Qb4 {[%clk 0:24:02.2]} 20. Qe2 {[%clk 0:26:22.4]} 20... Bxd4 {[%clk 0:23:43.5]} 21. Be6 {[%clk 0:26:10]} 21... Bxf2+ {[%clk 0:22:55.6]} 22. Rxf2 {[%clk 0:25:57.7]} 22... Rxf2 {[%clk 0:22:49.3]} 23. Qxf2 {[%clk 0:25:54.8]} 23... Nc6 {[%clk 0:22:13.1]} 24. Qd2 {[%clk 0:25:25.3]} 24... Qxd2 {[%clk 0:22:01.1]} 25. Bxd2 {[%clk 0:25:23.5]} 25... Rd8 {[%clk 0:21:57.9]} 26. Bg5 {[%clk 0:24:57.2]} 26... Nd4 {[%clk 0:21:52.2]} 27. Rd1 {[%clk 0:24:46.2]} 27... Nxe6 {[%clk 0:21:46.4]} 28. Bxd8 {[%clk 0:24:44.2]} 28... h6 {[%clk 0:21:36.3]} 29. Re1 {[%clk 0:24:35.9]} 29... Nxd8 {[%clk 0:21:30.1]} 30. Rxe4 {[%clk 0:24:33.5]} 30... Nc6 {[%clk 0:21:25.1]} 31. c4 {[%clk 0:24:23.6]} 31... Kh7 {[%clk 0:21:20.4]} 32. c5 {[%clk 0:24:19]} 32... b6 {[%clk 0:21:16.2]} 33. cxb6 {[%clk 0:24:17.6]} 33... axb6 {[%clk 0:21:15.6]} 34. Rc4 {[%clk 0:24:04.5]} 34... Na5 {[%clk 0:20:39.5]} 35. Rxc7 {[%clk 0:23:59.1]} 35... Kg6 {[%clk 0:20:35.2]} 36. h4 {[%clk 0:23:41.2]} 36... h5 {[%clk 0:20:32.2]} 37. Kg2 {[%clk 0:23:38.3]} 37... Kf5 {[%clk 0:20:25.8]} 38. Kf3 {[%clk 0:23:33.9]} 38... e4+ {[%clk 0:20:21.4]} 39. Ke3 {[%clk 0:23:32.6]} 39... Kg4 {[%clk 0:20:16.7]} 40. Rxg7+ {[%clk 0:23:28.5]} 40... Kf5 {[%clk 0:20:03.2]} 41. Rh7 {[%clk 0:23:15.7]} 41... Kg4 {[%clk 0:19:55.8]} 42. Kxe4 {[%clk 0:23:08.1]} 42... Kxg3 {[%clk 0:19:41.1]} 43. Rxh5 {[%clk 0:23:05.6]} 43... b5 {[%clk 0:19:30]} 44. Kd4 {[%clk 0:22:59.5]} 44... Nc4 {[%clk 0:19:24.9]} 45. Kc5 {[%clk 0:22:50.9]} 45... Kf3 {[%clk 0:18:56]} 46. Kxb5 {[%clk 0:22:45]} 46... Ke3 {[%clk 0:18:54.6]} 47. Kxc4 {[%clk 0:22:42.4]} 47... Kf3 {[%clk 0:18:49.9]} 48. Rf5+ {[%clk 0:22:41.3]} 48... Kg3 {[%clk 0:18:48.7]} 49. h5 {[%clk 0:22:40.4]} 49... Kh4 {[%clk 0:18:47.5]} 50. h6 {[%clk 0:22:39.4]} 50... Kg4 {[%clk 0:18:46.3]} 51. h7 {[%clk 0:22:38.5]} 51... Kxf5 {[%clk 0:18:45.2]} 52. h8=Q {[%clk 0:22:36.5]} 52... Kg6 {[%clk 0:18:39.7]} 53. Kd5 {[%clk 0:22:32.7]} 53... Kf5 {[%clk 0:18:37.4]} 54. Qf8+ {[%clk 0:22:28]} 54... Kg4 {[%clk 0:18:35.8]} 55. Ke4 {[%clk 0:22:25.9]} 55... Kg3 {[%clk 0:18:33.6]} 56. Ke3 {[%clk 0:22:22.6]} 56... Kg4 {[%clk 0:18:30.4]} 57. Qf4+ {[%clk 0:22:10.3]} 57... Kh5 {[%clk 0:18:23.3]} 58. Qg3 {[%clk 0:22:05.8]} 58... Kh6 {[%clk 0:18:19.5]} 59. Qg4 {[%clk 0:22:03.4]} 59... Kh7 {[%clk 0:18:18.3]} 60. Kf4 {[%clk 0:22:02.3]} 60... Kh6 {[%clk 0:18:15.9]} 61. Kf5 {[%clk 0:21:53.8]} 61... Kh7 {[%clk 0:18:14.4]} 62. Kf6 {[%clk 0:21:40]} 62... Kh6 {[%clk 0:18:10.4]} 63. Qg6# {[%clk 0:21:37.6]} 1-0de'" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)