#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+(?:ST|DR|AVE|TRL|BLVD|LN|CT|RD|CV|CMNS|CRK|XING|SQ|CRST|LNDG|LOOP|OVAL|ROW|TER|TRCE)\b.*"
Local $sString = "505 BLACKBERRY" & @CRLF & _
"135 BEARDSLEY ST" & @CRLF & _
"15 HUNT CLUB DR" & @CRLF & _
"1223 STATE ROUTE 103" & @CRLF & _
"455 STATE RTE 43" & @CRLF & _
"206 COUNTY RD 4710" & @CRLF & _
"17 E 250TH ST" & @CRLF & _
"158 BALLINGER AVE SE" & @CRLF & _
"150 BALLINGER AVE S" & @CRLF & _
"18 BALLINGER AVE T" & @CRLF & _
"1272 ORANGE SUN TRL" & @CRLF & _
"291 S MORELAND BLVD" & @CRLF & _
"615 RUSSET WOOD LN" & @CRLF & _
"1165 MORROCCO CT" & @CRLF & _
"1321 S PKWY DR" & @CRLF & _
"250 COUNTY RD 25A S" & @CRLF & _
"22 SANSTONE RIDGE WAY" & @CRLF & _
"55070 MENDOZA TRL" & @CRLF & _
"1609 HUNTSMERE AVE DOWN" & @CRLF & _
"243 MISTY WOODS CV S" & @CRLF & _
"2292 BAYBERRY CMNS" & @CRLF & _
"16 KILDEER CRK" & @CRLF & _
"40 BEDFORD XING" & @CRLF & _
"4 LEXINGTON SQ" & @CRLF & _
"113 SPARROWS CRST" & @CRLF & _
"1082 MATHOM LNDG" & @CRLF & _
"1050 WILLOW RIDGE LOOP" & @CRLF & _
"660 REDTOP LOOP" & @CRLF & _
"8 MOUNT ROYAL LOOP" & @CRLF & _
"805 SIERRA OVAL" & @CRLF & _
"3012 NANTUCKET ROW" & @CRLF & _
"6 WOODROW AVE" & @CRLF & _
"943 DARROW PARK DR" & @CRLF & _
"743 BELVEDERE TER" & @CRLF & _
"189 WINCHESTER RD" & @CRLF & _
"19 WHITE OAK TRCE" & @CRLF & _
"890 BLACKJACK RD EXT" & @CRLF & _
"767 N EXCALIBUR DR" & @CRLF & _
"109 VININGS FOREST LN SE" & @CRLF & _
"508 E 141ST ST" & @CRLF & _
"85 ROSE LN ST SW"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)