import re
regex = re.compile(r",", flags=re.MULTILINE)
test_str = ("GROCERY\n"
"CHILD_NUTRITION_FOOD_PROGRAMS,GROCERY\n"
"FOOD_SERVICE\n"
"FOOD_SERVICE,GROCERY\n"
"CHILD_NUTRITION_FOOD_PROGRAMS\n"
"CHILD_NUTRITION_FOOD_PROGRAMS,FOOD_SERVICE\n"
"CHILD_NUTRITION_FOOD_PROGRAMS,FOOD_SERVICE,GROCERY\n"
"VENDING,ONLINE,MASS_MERCHANDISING,FOOD_SERVICE,MILITARY,CONVENIENCE,GROCERY,DRUG\n"
"ONLINE,CHILD_NUTRITION_FOOD_PROGRAMS,FOOD_SERVICE,GROCERY\n"
"ONLINE,FOOD_SERVICE\n"
"ONLINE,CONVENIENCE\n"
"ONLINE,GROCERY,DRUG\n"
"ONLINE,GROCERY\n"
"ONLINE,FOOD_SERVICE,GROCERY\n"
"ONLINE,FOOD_SERVICE,CONVENIENCE\n")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)