import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<p>)(.*?)(?=<\\/p>)(?:.*?)(?<=<span>)(.*?)(?=<\\/span>)";
final String string = "<div><p>HELLO1</p>\n"
+ " <span>SPIDER</span></div>\n"
+ "<div><p>HELLO2</p>\n"
+ " <span>CHEESE</span></div>\n"
+ " <div><p>HELLO3</p>\n"
+ " <span>BANANA</span></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}