re = /(?<!\bU\.[SK]|\bMr)\.\s/m
str = 'My name is Mr. Aishwarya. I live in the U.K. and want to go to U.S. Us will go to Australi. Who else wants to go to U.S.A. ? My wife\'s name is Ruchika Bhatt. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end