$re = '/[\n\r \t]+/m';
$str = '<h1>heading text that is not a c
tab b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);