import re
regex = re.compile(r"^\{((?:(?:(?!\}).)+)(?:(?:\}\})?(?:(?:(?!\}).)+))+)\}(?!\})", flags=re.MULTILINE)
test_str = ("{class: name}\n\n"
"{ class : name }\n\n"
"{ 'class' : 'name' }\n\n"
"{ 'key' : 'value', 'key': 'value' }\n\n"
"{'key': 'value'}\n\n"
"{' key ': ' value ' , 'this': 'guy' }\n\n"
"{' class ': ' in session ' , 'this': 'guy' } string\n\n"
"{' class ': ' in session ' , 'this': 'guy' } string with {{ brackets }}\n\n"
"{' class ': '{{ parse me }}' }\n\n"
"{'key': 'value', checked: true}\n\n"
"{'key': 'value', checked: {{ bool }} }\n\n"
"{'asdf': 'fda', checked: {{ bool }}, strange: {{ bool }} } stuff {{ more }} #{interpolate}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")