re = /(?<!\\)(?:\\.|[^\\\n])*?(s)/m
str = 'this is a test
this is a te\\st
this is a te\\\\st
this is a te\\\\\\st
this is a te\\\\\\\\st
this is a te\\\\\\\\\\st
this is a te\\\\\\\\\\\\st'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end