re = /\b\w+(?=[:\]](?![^\]\[]*\]))/
str = '[group:text]
icon_type:[search]:[asterisk]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end