using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*)([-+]?)([0-9,.]+)(\s*)([^-+\s*\/^])(.*)$";
string input = @"34 +";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}