$re = '/^[\s]*given/';
$str = ' given some books I\'ve given to my son.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);