import re
regex = re.compile(r"[\w-]+\.(?<!com\.)somehost(?:\.[\w-]+)+")
test_str = ("<endpoint address=\"https://subsite.somehost.com/someservice.svc\" ... \n"
" contract=\"com.somehost.subsite.someservice.MyServiceSoap\" />\n"
"<endpoint address=\"https://othersub.somehost.com/anotherservice.svc\" ...\n"
" contract=\"com.somehost.othersub.anotherservice.MyOtherServiceSoap\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")