re = /([^=\^]+)=([^\^]*)/m
str = 'Apr 23 21:43:22 3.111.9.101 CEF:0|Seqrite|EPS|5.2.1.0|Data Loss Prevention Event|^|channelType=Applications/Online Services^domainName=AVOTRIXLABS^endpointName=ALEI5-ANURAGR^groupName=Default^channelDetail=Microsoft OneDrive Client^documentName=^filePath=C:\\Users\\anurag.rathore.AVOTRIXLABS\\OneDrive - Scanlytics Technology\\Documents\\git\\splunk_prod\\deployment-apps\\Fleet_Management_Dashboard\\appserver\\static\\fontawesome-free-6.1.1-web\\svgs\\solid\\flask-vial.svg^macID1=9C-5A-44-0A-26-5B^status=Success^subject=^actionId=Skipped^printerName=^recipientList=^serverDateTime=Wed Apr 23 16:13:57 UTC 2025^matchedItem=Visa^sender=^contentType=Confidential Data^dataId=Client Application^incidentOn=Wed Apr 23 16:07:38 UTC 2025^ipAddressFromClient=***.***.*.16^macID2=00-FF-58-34-31-0E^macID3=B0-FC-36-CA-1C-73^userName=anurag.rathore
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end