re = /(?=\S)((?).){0,13}\S*/m
str = 'When done correctly, heat exposure offers tremendous benefits. However, it is extremely dangerous to use temperatures that are too hot. What is too hot? That will depend.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end