import re
regex = re.compile(r"(?s)\.GetModification(?:String|Number|Bool|Object|Array)\(\s*[\"']([\w\-]+)['\"]\s*,\s*([\"'][^\"]*['\"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|\"[^\"]*\"))?\s*\)", flags=re.MULTILINE)
test_str = (" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\", true)\n"
" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"sjkfhskd\", true)\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13, true)\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false, true)\n\n"
" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", 13)\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", false)\n\n"
" discountName, err := fsVisitor.GetModificationString(\"btnColor\", \"VString\")\n"
" discountName, err := fsVisitor.GetModificationNumber(\"btnSize\", \"red, green, blue\", false)\n"
" discountName, err := fsVisitor.GetModificationBool(\"showBtn\", \"(false moha)\")\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")