package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^<](?R)?<BckSp>`)
var str = `Helllo<BckSp><BckSp>o world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}