package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#(\w+)(?:[, .]|$)`)
var str = `hi #myname, you got #amount`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}