import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\[(\\d+)\\].*$";
final String string = "carousels['components'][0][0][title]\n"
+ "carousels['components'][0][1][title]\n"
+ "carousels['components'][0][2][title]\n\n"
+ "carousels['components'][1][0][title]\n"
+ "carousels['components'][1][1][title]\n"
+ "carousels['components'][1][2][title]\n\n"
+ "carousels['components'][2][0][title]\n"
+ "carousels['components'][2][1][title]\n"
+ "carousels['components'][2][2][title]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}