re = /^(\w{2}-\w{2})\/questions(?:\/(\w+))?(?:\/(\d+))?(?:\/.*?)?$/m
str = 'en-us/questions/ask
en-us/questions/newest/15
en-us/questions/12/just-a-text-to-be-ignored'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end