re = /(?=(?:.*[a-z]){2,})(?=(?:.*[A-Z]){2,})(?=(?:.*\d){2,})(?=(?:.*[@#$%^&+=]){2,})/
str = '#Aa15@aAAAsS'
# Print the match result
str.match(re) do |match|
puts match.to_s
end