$re = '/[^\p{L}\p{M}\'\s\.\-]+/i';
$str = 'fjdskjfdkls
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);