# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<unit_design>Z)(?P<unit_type>SFW|SF)(?P<unit_size>200|160|125|100|32|40|50|63|80)(?P<mounting_type>F)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>1X|2X)(?P<sep_3>/)(?P<seal_material>M|V)(?P<sep_4>/)(?P<pipe_port>12|01)(?P<orifice_position>D|)(?P<orifice_diameter>00|08|10|12|15|40|)(?P<additional_details>(.|[0-9])*)$"
test_str = ("ZSF40F1-1-1X/M/01\n"
"ZSF40F0-1-1X/M/01\n"
"ZSF100F0-1-1X/M/01\n"
"ZSF80F1-1-1X/M/01D00\n"
"ZSF50F1-1-1X/M/01D00\n"
"ZSFW40F1-1-1X/M/01\n"
"ZSF100F1-1-1X/M/01\n"
"ZSFW100F1-1-1X/M/01\n"
"ZSF63F1-1-1X/M/01D00\n"
"ZSF80F0-1-1X/M/01D00\n"
"ZSF50F0-1-1X/M/01D00\n"
"ZSFW50F1-1-1X/M/01\n"
"ZSF40F0-1-1X/M/01SO1\n"
"ZSF63F0-1-1X/M/01D00\n"
"ZSFW80F0-1-1X/M/01\n"
"ZSFW100F0-1-1X/M/01\n"
"ZSFW80F1-1-1X/M/01\n"
"ZSF50F0-1-1X/M/01SO1\n"
"ZSF32F0-1-1X/M/01SO1\n"
"ZSF63F0-1-1X/M/01SO1\n"
"ZSFW160F0-1-1X/M/01\n"
"ZSFW40F0-1-1X/M/01\n"
"ZSFW63F1-1-1X/M/01\n"
"ZSFW63F0-1-1X/M/01\n"
"ZSFW50F0-1-1X/M/01\n"
"ZSF160F1-1-1X/M/01\n"
"ZSFW160F1-1-1X/M/01\n"
"ZSF160F0-1-1X/M/01\n"
"ZSF32F0-1-1X/M/01\n"
"ZSF32F1-1-1X/M/01SO6\n"
"ZSF100F1-1-1X/V/01\n"
"ZSF100F0-1-1X/M/01SO1\n"
"ZSF50F1-1-1X/M/01SO6\n"
"ZSF40F1-1-1X/M/01SO6\n"
"ZSFW32F0-1-1X/M/01\n"
"ZSF32F1-1-1X/M/01\n"
"ZSF80F0-1-1X/M/01SO1\n"
"ZSF80F1-1-1X/M/01SO1\n"
"ZSFW100F1-1-1X/V/01\n"
"ZSFW50F1-1-1X/V/01\n"
"ZSFW32F1-1-1X/M/01\n"
"ZSF160F0-1-1X/V/01\n"
"ZSF125F0-1-2X/M/01\n"
"ZSF125F1-1-2X/M/01\n"
"ZSFW125F1-1-2X/M/01\n"
"ZSFW125F0-1-2X/M/01\n"
"ZSF125F0-1-2X/V/01\n"
"ZSF125F1-1-2X/V/01\n"
"ZSFW125F0-1-2X/V/01\n"
"ZSF125F0-1-2X/M/01SO1\n"
"ZSF100F0-1-1X/V/01\n"
"ZSF63F0-1-1X/V/01D00\n"
"ZSF50F0-1-1X/V/01D00\n"
"ZSFW100F0-1-1X/V/01\n"
"ZSFW63F0-1-1X/V/01\n"
"ZSFW50F0-1-1X/V/01\n"
"ZSF125F1-1-2X/M/01SO6\n"
"ZSF200F0-1-2X/M/01D40\n"
"ZSFW200F0-1-2X/M/01D40\n"
"ZSFW125F1-1-2X/M/01SO6\n"
"ZSFW63F1-1-1X/V/01\n"
"ZSFW40F0-1-1X/V/01\n"
"ZSF160F1-1-1X/M/01SO12\n"
"ZSF125F0-1-2X/M/01SO6\n"
"ZSF160F0-1-1X/M/01SO6\n"
"ZSFW160F0-1-1X/M/01SO12\n"
"ZSF80F0-1-1X/V/01D00\n"
"ZSFW200F0-1-2X/V/01D40\n"
"ZSF100F0-1-1X/M/01SO13\n"
"ZSF125F0-1-2X/M/01SO13\n"
"ZSF125F0-1-2X/M/01SO14\n"
"ZSF63F0-1-1X/M/01D08\n"
"ZSF50F0-1-1X/M/01D08\n"
"ZSF80F0-1-1X/M/01D10\n"
"ZSF160F1-1-1X/M/01SO6\n"
"ZSF32F1-1-1X/M/01D08\n"
"ZSF100F0-1-1X/M/01D10\n"
"ZSF125F0-1-2X/M/01D12\n"
"ZSF160F0-1-1X/M/01D15\n"
"ZSF100F1-1-1X/M/01D10SO6\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.