package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*ABC.*`)
var str = `<b>ABCDEFasdfasd345%0<bb>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}