import Foundation
let pattern = #""amount":"[\$]?([0-9]{1,3}),([0-9]{1,3})""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[{"team":"Green Bay Packers","active":"1","year_started":"2018","end_year":"2022","amount":"$2,578,408","amount_guaranteed":"$118,408"}]
[{"team":"San Diego Padres","active":"0","year_started":"2020","end_year":"2020","amount":"563,500","amount_guaranteed":""},{"team":"San Diego Padres","active":"0","year_started":"2019","end_year":"2019","amount":"555,000","amount_guaranteed":""}]
[{"team":"Washington Wizards","active":"1","year_started":"2019","end_year":"2021","amount":"$12,000,000","amount_guaranteed":"$12,000,000"},{"team":"Orlando Magic","active":"0","year_started":"2011","end_year":"2011","amount":"522,472","amount_guaranteed":""},{"team":"Orlando Magic","active":"0","year_started":"2012","end_year":"2013","amount":"2,854,389","amount_guaranteed":""},{"team":"Oklahoma City Thunder","active":"0","year_started":"2014","end_year":"2014","amount":"923,373","amount_guaranteed":""},{"team":"Houston Rockets","active":"0","year_started":"2014","end_year":"2014","amount":"981,084","amount_guaranteed":""},{"team":"Washington Wizards","active":"0","year_started":"2015","end_year":"2015","amount":"1,100,602","amount_guaranteed":""},{"team":"Detroit Pistons","active":"0","year_started":"2016","end_year":"2018","amount":"18,000,000","amount_guaranteed":""}]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""amount":"$1$2","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)